Supports de 1.11 Released! How to Install it in Ubuntu via PPA

brackets code editor

Adobe Brackets, a modern open-source code editor for the web, a atteint le 1.11 Il y a un jour de libération. Voici comment l’installer dans Ubuntu 14.04, Ubuntu 16.04, Ubuntu 17.04, et dérivés.

What’s New in Brackets 1.11:

  • Brackets now supports ECMAScript 2015. Quick-type listing now shows classes, methods, arrow functions, generator functions and much more. Brackets also supports linting of ECMAScript 2015 code, with ESLint defaulting as Javascript linter, ainsi.
  • Brackets now offers full support for the Linux platform.
  • Fix a few minor issues found by lgtm.
  • Fix extension registry link in README.md
  • Fix CTRL+Space handling while the CodeHintList is open
  • Fix wrong function call in ProjectManager.js
  • Double click on search result header closes search results window
  • Add mapping for stylus mode in LanguageManager
  • Now reverse inspect can be disabled by setting the ‘livedev.enableReverseInspect’ pref to false
  • Upgrade brackets-eslint to 3.2.0
  • Voir le note d’accompagnement pour en savoir plus.

How to Install Brackets 1.11 dans Ubuntu :

Adobe offers the official .deb packages in the github release page.

For those who want to receive updates though Software Updater, vous pouvez utiliser le Webupd8Team PPA which provides Brackets packages for Ubuntu 14.04, Ubuntu 16.04, Ubuntu 17.04, et dérivés.

1. Ouvrir un terminal via Ctrl + Alt + T ou de lanceur d’applications. Exécutez la commande pour ajouter le PPA :

sudo add-apt-repository ppa:webupd8team / supports

Saisissez votre mot de passe (aucun retour visuel lors de la frappe) lorsqu’il invite et appuyez sur ENTREE..

2. Then you’re able to upgrade the code editor via Software Updater utility:

or install it for the first time via commands:

sudo apt-get update

sudo apt-get install brackets

Désinstaller :

Pour enlever le dépôt PPA, launch Software & Updates utility and navigate to Other Software tab.

To remove Brackets code editor, Utilisez le gestionnaire de package de système ou exécutez la commande :

sudo apt-get remove --autoremove brackets

Source

Laisser une réponse