PyCharm 2017.3.2 Udgivet! Sådan installeres det i Ubuntu

PyCharm 2017.3.2 Udgivet! Sådan installeres det i Ubuntu

Jetbrains announced the release of its Python IDE, PyCharm 2017.3.2, a day ago. Here’s how you can install it in Ubuntu 16.04 and higher.

Ændringer i PyCharm 2017.3.2 inkluderer:

  • Type annotation ahead of time. You can’t put an inline type annotation when defining a variable in a for or a with statement, so you need to provide the annotation in a separate place, læs mere på billetten. Dette understøttes nu i PyCharm.
  • ‘Show command line afterwards’ now works correctly for remote interpreters. And further fixes to this feature
  • Forskellige SQL-syntaksrettelser til PostgreSQL og Oracle (PyCharm Professional Edition bundler alle DataGrip-funktioner)
  • Reaktér kodeforbedringsforbedringer (PyCharm Professional Edition kombinerer alle WebStorm-funktioner)
  • Og mere, se udgivelsesnoterne for detaljer

PyCharm 2017.3.2 Udgivet! Sådan installeres det i Ubuntu

Sådan installeres PyCharm 2017.3.2 i Ubuntu:

Du kan nemt køre den nye version i Ubuntu enten via:

metode 1: officielle Linux-binære filer. NON-INSTALL version, skal du kun udpakke og køre eksekverbar fil for at starte IDE:

Download PyCharm Linux binært

metode 2: eller installer Snap-pakken. App kører i sandkasse. Understøttelse af Ubuntu 16.04 og højere:

Simply open terminal via Ctrl+Alt+T or by searching for ‘terminal’ from app launcher. When it opens, run command:

snap install pycharm-community - klassisk

PyCharm 2017.3.2 Udgivet! Sådan installeres det i Ubuntu

For professionel udgave, kør følgende kommando i stedet:

snap install pycharm-professionel - klassisk

Når du er installeret, skal du starte IDE'en fra din program launcher og nyd!

Afinstaller:

For at fjerne snap pakkerne, brug enten Ubuntu Software eller Kør kommandoen i terminal:

sudo snap fjerne pycharm-community pycharm-professionelle

For dem der foretrækker traditionel Ubuntu PPA, hold øje med launchpad PPA.

Kilde

Annoncer

Efterlad et svar

GTranslate Your license is inactive or expired, please subscribe again!