Technology Blog

Corebird 1.3.3 Released, How to Install it in Ubuntu 16.10, 16.04

0

Corebird Twitter Client

The GTK 3 twitter application Corebird 1.3.3 has been released. Here’s how to install it in Ubuntu 16.10, and/or Ubuntu 16.04.

Corebird 1.3.3 changelog:

  • Support longer tweets in a few more places
  • Properly escape ampersand characters in user mentions to fix GtkLabel warnings about wrong escape characters in tooltips
  • Fix tweet length calculations for whitespace-only tweets
  • Check for duplicated entries in media arrays. This is apparently a problem on Twitter’s side but led to crashes in Corebird
  • Use the correct nsfw status of a tweet, i.e. the one that can actually show images.
  • Fix a crash when sending a tweet with multiple images attached
  • Fix tweet length calculation of quote tweets. This previously led to tweets getting rejected by the server even though Corebird claimed they were fine.

Corebird

Corebird with Numix GTK theme

How to install/upgrade Corebird 1.3.3:

For Ubuntu 16.10, Ubuntu 16.04, and Linux Mint 18, follow the steps below to install or upgrade this native Linux twitter client via PPA:

1. Open terminal (Ctrl+Alt+T) and run command to add the PPA:

sudo add-apt-repository ppa:ubuntuhandbook1/corebird

corebird-ppa

2. Then upgrade Corebird from a previous release via Software Updater:

upgrade corebird 1.3.1

Or install it for the first time using the command:

sudo apt update && sudo apt install corebird

Source